效实中学

       栏目导航 网站首页>>资源中心>>电脑硬件 >>交换机
共有 14251 位读者读过此文   
 

四级网络工程师所有书中命令集合

  发表日期:2011年6月20日            【编辑录入: 叶建勇 】      宽屏显示

一、交换部分

1.显示交换表
大型交换机:
Swtich-6509#show cam dynamic
小型交换机:
Switch-3548#show mac-address-table

2.连接交换机Console口进行配置
使用RJ-45到9针或25针异步串行接口的信号电缆
速率          9600
数据位        8
奇偶效验      无
停止位        1
数据流控制    硬件

3.进入特权模式
Switch-3548>enable
Swtich-6509>enable

4.配置主机名:
Switch-3548(config)#hostname Switch1
Swtich-6509>(enable)set system name Switch1

5.设置系统提示:
Swtich-6509>(enable)set prompt Switch1

6.配置超级用户口令
Switch-3548(config)#enable password cisco (明文口令)
Switch-3548(config)#enable password 7 cisco (加密口令)
Switch-3548(config)#enable secret cisco   (加密口令)

Swtich-6509>(enable)set enablepass

7.配置远程登录口令
Switch-3548(config)#line vty 0 4
Switch-3548(config-line)#password 0 zzz   (明文口令)
Switch-3548(config-line)#password 7 zzz   (加密口令)

Swtich-6509>(enable)set password

8.设置系统时间
Switch-3548#clock set 21:11:12 24 May 2010

Swtich-6509>(enable)set time fri 2/23/2007 23:00:00

9.配置设备管理IP地址
Switch-3548(config)#interface vlan1
Switch-3548(config-if)#ip address 10.0.0.5 255.255.255.0 (配置IP地址为10.0.0.5/24)
Switch-3548(config-if)#ip default-gateway 10.0.0.1 (配置缺省路由为10.0.0.1)

Swtich-6509>(enable)set interface sc0 10.0.0.5 255.255.255.0 10.0.0.255 (配置IP地址为10.0.0.5/24 最后为广播地址)
Swtich-6509>(enable)set ip route 0.0.0.0 10.0.0.1 (配置缺省路由为10.0.0.1 0.0.0.0表示缺省路由)

10.配置交换机端口描述信息
Switch-3548(config)#interface fa0/2
Switch-3548(config-if)#description This_is_to_Xianan (设置描述信息为This_is_to_Xianan)

Swtich-6509>(enable)set port name 0/2 This_is_to_Xianan (设置描述信息为This_is_to_Xianan)

11.开启关闭端口
Switch-3548(config)#interface fa0/2
Switch-3548(config-if)#shutdown    (关闭端口)
Switch-3548(config-if)#no shutdown (开启端口)

Swtich-6509>(enable)set port enable 0/2   (关闭端口)
Swtich-6509>(enable)set port disable 0/2 (开启端口)

12.配置交换机端口通信方式
Switch-3548(config)#interface fa0/2 (进入端口)
Switch-3548(config-if)#deplex auto   (设置端口为自适应)
Switch-3548(config-if)#duplex full   (设置端口为全双工)
Switch-3548(config-if)#duplex half   (设置端口为半双工)

Swtich-6509>(enable)set port duplex 0/1 full     (设置端口为全双工)
Swtich-6509>(enable)set port duplex 0/1-24 full
Swtich-6509>(enable)set port duplex 0/1 half     (设置端口为半双工)
Swtich-6509>(enable)set port duplex 0/1-24 half

12.配置交换机端口传输速率
Switch-3548(config-if)#speed auto    (设置端口自动速率配置)
Switch-3548(config-if)#speed 100    (设置端口速率为100M)
Switch-3548(config-if)#speed 10    (设置端口速率为10M)

Swtich-6509>(enable)set port speed 0/1 auto      (设置端口自动速率配置)
Swtich-6509>(enable)set port speed 0/1-24 auto
Swtich-6509>(enable)set port speed 0/1-24 10      (设置端口速率为10M)
Swtich-6509>(enable)set port speed 0/1-24 100     (设置端口速率为100M)
Swtich-6509>(enable)set port speed 0/1-24 1000    (设置端口速率为1000M)

13.配置VTP
Switch-3548#config t
Switch-3548(config)#vtp domain cisco      (设置VTP域名为cisco)
Switch-3548(config)#vtp mode server       (设置为VTP Server模式,缺省值)
Switch-3548(config)#vtp mode client       (设置为VTP client模式)
Switch-3548(config)#vtp mode transparent (设置为VTP Transparent模式)
Switch-3548(config)#vtp password cisco    (设置为VTP密码为cisco)


Swtich-6509>(enable)set vtp domain cisco      (设置VTP域名为cisco)
Swtich-6509>(enable)set vtp mode server       (设置为VTP Server模式,缺省值)
Swtich-6509>(enable)set vtp mode client       (设置为VTP client模式)
Swtich-6509>(enable)set vtp mode transparent (设置为VTP Transparent模式)
Swtich-6509>(enable)set vtp password cisco    (设置为VTP密码为cisco)
Swtich-6509>(enable)set vtp mode off          (关闭VTP)

14.建立和删除VLAN
老版本:
Switch-3548#config t
Switch-3548(config)#vlan data
Switch-3548(vlan)#vlan 200 name vlan200 (建立vlan 200,命名为vlan200)
Switch-3548(vlan)#vlan 200 name v200     (修改vlan 200,命名为v200)
Switch-3548(vlan)#no vlan 200      (删除vlan 200)
Switch-3548(vlan)#exit
新版本:
Switch-3548#config t
Switch-3548(config)#vlan 200         (建立vlan 200)
Switch-3548(config-if)#name vlan200 (命名为vlan200)
Switch-3548(config-if)#exit
Switch-3548(config)#no vlan 200 (删除vlan 200)

Swtich-6509>(enable)set vlan 200 name vlan200      (建立vlan 200,命名为vlan200)
Swtich-6509>(enable)set vlan 200 name v200       (修改vlan 200,命名为v200)
Swtich-6509>(enable)clear vlan 200       (删除vlan 200)

Switch-3548(config)#interface fa0/1
Switch-3548(config-if)#switchport mode access   (设置端口模式为access)
Switch-3548(config-if)#switchport mode trunk    (设置端口模式为trunk)
Switch-3548(config-if)#switchport access vlan 200 (将端口分配到vlan200)

Swtich-6509>(enable)set vlan 200 0/1 (将端口0/1划分到vlan 200)

15.VLAN Trunk 的配置
Switch-3548(config-if)#switchport mode trunk    (设置端口模式为trunk)
Switch-3548(config-if)#switchport trunk encapsulation dot1q    (封装IEEE 802.1Q)
Switch-3548(config-if)#switchport trunk encapsulation ISL (封装ISL)
Switch-3548(config-if)#switchport trunk encapsulution negotiate P (自动协商封装方式)
Switch-3548(config-if)#switchport trunk allowed vlan 10,14   (设置允许中继的VLAN 10 24)
Switch-3548(config-if)#switchprot trunk allowed vlan 10-24 (设置允许中继的VLAN 10-24)
Switch-3548(config-if)#switchport trunk allowed valn except 100-1000 (除去100-1000的VLAN,其他允许中继)

Swtich-6509>(enable)set trunk 0/1 on dot1q   (设置端口0/1模式为trunk 封装IEEE 802.1Q)
Swtich-6509>(enable)set trunk 0/1 vlan 10-24   (设置允许中继的VLAN 10-24)
Swtich-6509>(enable)clear trunk 0/1 vlan 13-20   (除去13-20的VLAN,其他允许中继)

16.打开关闭STP
Switch-3548(config)#spanning-tree valn 3 (VLAN3启用STP)
Switch-3548(config)#no spanning-tree vlan 3 (VLAN3关闭STP)

Swtich-6509>(enable)set spantree enable 3   (VLAN3启用STP)
Swtich-6509>(enable)set spantree disable 3 (VLAN3关闭STP)

17.配置根网桥和备份根网桥
Switch-3548(config)#spanning-tree vlan 3 root primary (配置VLAN3为主根网桥)
Switch-3548(config)#spanning-tree vlan 3 root secondary (配置VLAN3为备份根网桥)

Swtich-6509>(enable)set spantree root 1,200-204   (配置VLAN1,VLAN200-VLAN204为主根网桥)
Swtich-6509>(enable)set spantree root 1,200-204   (配置VLAN1,VLAN200-VLAN204为备份根网桥)
Swtich-6509>(enable)set spantree disable 3 (VLAN3关闭STP)

18.配置生成树优先级
Switch-3548(config)#spanning-tree vlan 3 priority 8192 (配置VLAN3的优先级为8192)

Swtich-6509>(enable)set spantree priority 8192 (配置优先级为8192)

19.配置生成树可选项
Switch-3548(config)#spanning-tree backbonefast (允许backbonefast功能)

Swtich-6509>(enable)set spantree backbonefast enable (允许backbonefast功能)

Switch-3548(config)#spanning-tree uplinkfast max-update-rate 32000 (uplinkfast功能max-update-rate值为32000)
Switch-3548(config)#spanning-tree uplinkfast (允许uplinkfast功能)

Swtich-6509>(enable)set spantree uplinkfast enable (允许uplinkfast功能)
Swtich-6509>(enable)set spantree uplinkfastenable rate 32000 (uplinkfast功能max-update-rate值为32000)

Switch-3548(config)#spanning-tree portfast enable   (打开portfast)
Switch-3548(config)#spanning-tree portfast disable (关闭portfast)
Switch-3548(config)#spanning-tree portfast default (缺省启用portfast)

Swtich-6509>(enable)set spantree portfast enable (允许portfast功能)
Swtich-6509>(enable)set spantree portfast disable (关闭portfast功能)
Swtich-6509>(enable)set spantree portfast default (缺省启用portfast功能)

Switch-3548(config)#spanning-tree portfast bpdufilter befault (缺省启用bpdu filter)

Swtich-6509>(enable)set spantree bpdu-filter enable (所有端口启用bpdu-filter功能)
Swtich-6509>(enable)set spantree bpdu-filter disable (关闭bpdu-filter功能)
Swtich-6509>(enable)set spantree bpdu-filter default (缺省启用bpdu-filter功能)
Swtich-6509>(enable)set spantree bpdu-filter 0/1-24 enable (打开0/1-24的bpdu-filter功能)

二、路由器配置

路由器接口配置
Router(config)#int g1/2   (进入g1/2接口)
Router(config-if)#description To-Beijin University (配置接口描述信息为To-Beijin University)
Router(config-if)#bandwidth 2500000 (设置接口带宽为2.5Gbps)
Router(config-if)#ip address 202.112.7.249 255.255.255.252 (配置接口IP地址)
Router(config-if)#shutdown   (关闭接口)
Router(config-if)#no shutdown (开启接口)
Router(config-if)#no ip directed-broadcast (禁止定向广播通过此接口)
Router(config-if)#no ip proxy-arp (禁止代理ARP)

Router(config)#interface a1 (进入异步串行接口a1)
Router(config-if)#ip unnumbered ethernet0
Router(config-if)#encapsulation ppp
Router(config-if)#async default ip address 202.112.7.129
Router(config-if)#async dynamic routing
Router(config-if)#async mode interactive
Router(config-if)#no shutdown

Router(config)#interface s1/1 (进入高速同步串行接口s1/1)
Router(config-if)#description To-Shanhai
Router(config-if)#bandwidth 2048
Router(config-if)#ip address 202.112.7.129 255.255.255.252
Router(config-if)#encapsulation hdlc
Router(config-if)#no shutdown (开启接口)
Router(config-if)#no ip directed-broadcast (禁止定向广播通过此接口)
Router(config-if)#no ip proxy-arp (禁止代理ARP)

Router(config)#interface POS3/0 (进入接口POS3/0)
Router(config-if)#description To-Wuhan
Router(config-if)#bandwidth 2500000
Router(config-if)#ip address 202.112.7.129 255.255.255.252
Router(config-if)#crc 32               (可选的CRC校验位是32)
Router(config-if)#pos framing sdh     (可选帧格式为SDH)
Router(config-if)#no ip directed-broadcast (禁止定向广播通过此接口)
Router(config-if)#pos flag s1s0 2 (s1s0=00表示是SONET帧的数据,s1s0=10(十进制2)表示是SDH帧的数据)
Router(config-if)#no shutdown (开启接口)

Router(config)#interface loopback 0 (进入回环接口loopback0)
Router(config-if)#ip address 192.167.176.6 255.255.255.255 (配置接口IP地址,注意掩码)
Router(config-if)#no ip route-cache
Router(config-if)#no ip mroute-cache

静态路由配置
Router(config)#ip route 10.0.0.0 255.255.255.0 192.168.1.1 (目的网络地址、子网掩码、下一跳路由器IP)

RIP动态路由配置
Router(config)#router rip (启用并进入RIP路由协议配置模式)
Router(config-router)#network 159.105.0.0 (设置参与RIP协议的网络地址)
Router(config-router)#network 212.112.7.0
Router(config-router)#exit

Router(config)#router rip (启用并进入RIP路由协议配置模式)
Router(config-router)#passive-interface ethernet 0 (e0接口启用被动接口)
Router(config-router)#exit

Router(config)#access-list 12 deny any (建立标准扩展列表12)
Router(config)#router rip (启用并进入RIP路由协议配置模式)
Router(config-router)#distribute-list 12 in ethernet0 (e0接口启用路由过滤功能)
Router(config-router)#exit

Router(config)#router rip (启用并进入RIP路由协议配置模式)
Router(config-router)#network 159.105.0.0 (设置参与RIP协议的网络地址)
Router(config-router)#network 212.112.7.0
Router(config-router)#distance 50   (设置管理距离为50)
Router(config-router)#neighbor 202.112.7.2 (设置邻居路由器地址为202.112.7.2)
Router(config-router)#exit

OSPF动态路由配置
Router(config)#router ospf 100 (启用并进入OSPF路由协议配置模式,进程号100)
Router(config-router)#network 131.107.25.1 0.0.0.0 area 0 (设置参与OSPF协议的网络地址,区域0)
Router(config-router)#network 133.181.0.0 0.0.255.255 area 0 (设置参与OSPF协议的网络地址,区域0)
Router(config-router)#area 0 range 212.37.123.0 255.255.255.0 (定义参与OSPF的子网地址)

Router(config)#router ospf 200 (启用并进入OSPF路由协议配置模式,进程号200)
Router(config-router)#passive-interface ethernet 0 (e0接口启用被动接口)
Router(config-router)#passive-interface vlan37 (vlan37启用被动接口)

Router(config)#access-list 12 deny any (建立标准扩展列表12)
Router(config)#router ospf 200 (启用并进入OSPF路由协议配置模式,进程号200)
Router(config-router)#distribute-list 12 in serial 0 (S0接口启用路由过滤功能)
Router(config-router)#exit

Router(config)#router ospf 100 (启用并进入OSPF路由协议配置模式,进程号100)
Router(config-router)#network 131.107.25.1 0.0.0.0 area 0 (设置参与OSPF协议的网络地址,区域0)
Router(config-router)#network 133.181.0.0 0.0.255.255 area 0 (设置参与OSPF协议的网络地址,区域0)
Router(config-router)#distance 10 (设置管理距离为10)
Router(config-router)#redistribute metric 100 (设置OSFP引入外部路由的花费值为100)
Router(config-router)#redistribute tag 10 (设置OSFP引入外部路由时缺省的标记值为10)
Router(config-router)#redistribut connected metric-type 1 subnets(设置OSFP引入外部路由时缺省的外部路由类型为1)


三、安全配置

DHCP服务器的配置(必要五步1建池、2网段、3缺省网关、4DNS、5租约时间)
Router(config)#ip dhcp pool mydhcp (配置IP地址池的名称为mydhcp,并进入DHCP Pool配置模式)
Router(dhcp-config)#network 201.23.98.0 255.255.255.0 (配置IP地址池的子网地址和子网掩码)
Router(dhcp-config)#network 201.23.98.0/24 (配置IP地址池的子网地址和子网掩码)
Router(dhcp-config)#default-router 201.23.98.1 (配置IP地址池的缺省网关为201.23.98.1)
Router(dhcp-config)#domain-name pku.edu.cn (配置IP地址池的域名系统)
Router(dhcp-config)#dns-server address 201.105.126.27 212.105.129.26 (配置IP地址池的域名服务器地址)
Router(dhcp-config)#lease 0 5 30 (配置IP地址池的地址租用时间为0天5小时30分)
Router(dhcp-config)#lease infinitr (配置IP地址池的地址租用时间为不限制时间)
Router(dhcp-config)#exit
Router(config)#no ip dhcp conflict logging (取消地址冲突记录日志)

Router(config)#ip dhcp excluded-address 201.23.98.2 201.23.98.10 (配置不用于动态分配的地址,排除从201.23.98.2到201.23.98.10的一段IP地址)
Router(config)#ip dhcp excluded-address 201.23.98.2 (配置不用于动态分配的地址,排除201.23.98.2单个地址)

访问控制列表的配置

标准访问控制列表(1-99 只限制源地址 两步1建立ACL、2应用于接口)
Router(config)#access-list 10 permit 211.105.130.0 0.0.0.255 (建立标准访问控制列表10,允许源地址211.105.130.0/24网络)
Router(config)#line vty 0 4     (进入vty端口模式)
Router(config-line)#access-class 10 in   (将访问控制列表10应用在进接口)

Router(config)#access-list 30 deny 10.0.0.0 0.255.255.255 log
Router(config)#access-list 30 deny 192.168.0.0.255.255
Router(config)#access-list 30 deny 172.16.0.0 0.15.255.255
Router(config)#access-list 30 permit any
Router(config)#interface g0/1
Router(config-if)#ip access-group 30 in

扩展访问控制列表(100-199)
Router(config)#access-list 130 deny udp any any eq 1434 (拒接转发所有IP地址进出的,端口号为1434的UDP协议数据包)
Router(config)#access-list 130 permit ip any any
Router(config)#interface g0/1
Router(config-if)#ip access-group 130 in
Router(config-if)#ip access-group 130 out

Router(config)#access-list 110 deny ip host 202.112.60.230 any log (封禁IP地址为202.112.60.23的主机)
Router(config)#access-list 110 deny ip any host 202.112.60.230 log
Router(config)#access-list 110 permit ip any any
Router(config)#interface g0/1
Router(config-if)#ip access-group 110 in
Router(config-if)#ip access-group 110 out

Router(config)#access-list 198 permit icmp 162.105.141.0 0.0.0.255 any (封禁ICMP协议,只允许162.105.141/24子网的ICMP数据包通过路由器)
Router(config)#access-list 198 deny icmp any any
Router(config)#access-list 198 permit ip any any
Router(config)#interface g0/1
Router(config-if)#ip access-group 198 in
Router(config-if)#ip access-group 198 out

Router(config)#ip access-list extended 130 (拒接转发所有IP地址进出的,端口号为1434的UDP协议数据包)
Router(config-ext-nacl)#deny upd any any eq 1434
Router(config-ext-nacl)#permit ip any any
Router(config-ext-nacl)#exit
Router(config)#interface g0/1
Router(config-if)#ip access-group 130 in
Router(config-if)#ip access-group 130 out


Router(config)#ip access-list standard mylist (禁止源地址为非法地址的数据包进入路由器或从路由器输出)
Router(config-std-nacl)#deny 10.0.0.0 0.255.255.255 log
Router(config-std-nacl)#deny 192.168.0.0 0.0.255.255
Router(config-std-nacl)#deny 172.16.0.0 0.15.255.255
Router(config-std-nacl)#permit any
Router(config-std-nacl)#exit
Router(config)#interface g0/1
Router(config-if)#ip access-group mylist in
Router(config-if)#ip access-group mylist out

Router(config)#ip access-list extended myextlist (拒接转发所有IP地址进出的,端口号为1434的UDP协议数据包)
Router(config-ext-nacl)#deny upd any any eq 1434
Router(config-ext-nacl)#permit ip any any
Router(config-ext-nacl)#exit
Router(config)#interface g0/1
Router(config-if)#ip access-group myextlist in
Router(config-if)#ip access-group myextlist out

防火墙的配置
Pix525(config)#nameif ethernet0 outside security0 (配置防火墙的接口名字并指定安全级别(数字越大安全级别越高))
Pix525(config)#nameif ethernet0 inside security100
Pix525(config)#nameif dmz security50

Pix525(config)#interface ethernet0 auto (配置e0口自动协商方式)
Pix525(config)#interface ethernet1 100full (配置e1口采用100Mbps全双工通信)

Pix525(config)#ip adddress outside 202.113.79.1 255.255.255.240 (配置外网的ip地址)
Pix525(config)#ip adddress inside 192.168.0.1 255.255.255.0 (配置内网的ip地址)

Pix525(config)#net (inside) 1 192.168.0.1 255.255.255.0 (192.168.0.1这个网段内的主机可以访问外网)

Pix525(config)#global(outside) 1 202.113.79.1-202.113.79.14 (设置外部地址池为202.113.79.1至202.113.79.14)

Pix525(config)#router outside 0 0 202.81.20.1 1 (设置指向内网和外网的静态路由为202.81.20.1)

Pix525(config)#static (inside,outside) 202.113.79.4 192.168.0.4 (建立了内部IP地址192.168.0.4和外部地址202.113.79.4之间的静态映射)

Pix525(config)#conduit permit tcp host 192.168.0.4 eq www any (允许任何外部主机对全局地址192.168.0.4的这台主机进行http访问)

Pix525(config)#fixup protocol http 80 (启用http协议,并指定端口为80,通过pix防火墙)
Pix525(config)#no fixup protocol smtp (禁止smtp协议通过pix防火墙)


SNMP设置
(config)#snmp-server community public ro 4 (建立一个团体,团体名称为public,访问权限为只读,管理站的IP地址范围由4号ACL规定)
(config)#snmp-server community admin view part rw (建立一个团体,团体名称为admin,访问权限为可读写,访问MIB库的范围由视阈part规定)

(config)#snmp-server view part mib-2 included (建立一个视阈,名称为part,它包括mib-2整个子树的所有对象)

(config)#snmp-server view ext system included (建立一个视阈,名称为ext,它包括mib-2库中系统组的所有对象和Cisco私有库的所有对象)
(config)#snmp-server view ext cisco included


(config-if)#snmp trap link-status (在某个接口的配置模式下,指定当该接口端口或连接时要向管理站发出通知)

(config)#snmp-server enable traps (使该路由器可以向主机monitor.tj.edu.cn按照团体名public发送消息)
(config)#snmp-server host monitor.tj.edu.cn public

配置镜像端口
Switch(config)#monitor session 1 source interface Gi2/16 (配置被镜像端口)
Switch(config)#monitor session 1 destination interface Gi2/12 (配置镜像端口)
Switch#show monitor session 1 (检查镜像端口配置)


 
  打印本页